HubTran Currently Unvailable
Incident Report for HubTran
Resolved
We have pushed a resolution for our outage, and HubTran is now available for users.
Posted May 01, 2020 - 13:36 EDT
Identified
HubTran is currently unavailable for users. We are working on a solution for this now.
Posted May 01, 2020 - 13:32 EDT
This incident affected: Email Imports and Website.