HubTran Degraded Performance
Incident Report for HubTran
Resolved
This issue has been resolved. Worker presence and invoice processing is now functioning as expected.
Posted Mar 20, 2020 - 16:54 EDT
Investigating
Currently users in HubTran may experience issues with processing invoices and viewing worker presence. We are investigating this situation.
Posted Mar 20, 2020 - 16:45 EDT
This incident affected: Website.