Degraded Performance
Incident Report for HubTran
Resolved
This incident has been resolved. Have a wonderful day!
Posted Jul 28, 2021 - 10:46 EDT
Monitoring
Thank you for your patience, a fix has been released and we are currently monitoring the situation.
Posted Jul 28, 2021 - 09:54 EDT
Investigating
HubTran is currently experiencing degraded performance, we are investigating and will update as we have additional information available.
Posted Jul 28, 2021 - 08:47 EDT
This incident affected: Website.